• Версия для печати

Скрипт: автоматическая установка ISPConfig 3 [Релизы]

Описание: Здесь размещены проекты серверных сборок и панелей управления вебхостингом
Правила раздела: Условием использования нашего форума, является соблюдение настоящих Правил форума.

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам, а вы рискуете получить предупреждение.
Модераторы: rewuxiin, kulia

Автор
Сообщение
SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#1 SinglWolf » Пн, 3 февраля 2014, 17:03

Тема только для анаонсов релизов скрипт: автоматическая online-установка панели управления web-хостингом ISPConfig 3.

Развёрнутое описание читайте в блогах

Обсуждение здесь
Последний раз редактировалось SinglWolf Вс, 10 апреля 2016, 8:39, всего редактировалось 63 раза.

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#2 SinglWolf » Вс, 10 апреля 2016, 8:33


SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#3 SinglWolf » Чт, 21 апреля 2016, 12:14

Для применения обновлений скрипта на установленной панели теперь будет создаваться отдельный архив с приставкой -upd.
Содержимое этого архива нужно распаковать в каталог скрипта из которого производилась установка панели с заменой файлов. Это сделать легко при помощи файлового менеджера MC

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#4 SinglWolf » Пт, 25 ноября 2016, 11:38

Небольшой анонс. В виду того, что вышла новая версия ISPConfig 3.1, готовится и обновление скрипта 4.1...
Будет поддержка ОС (+ к имеющимся)
Ubuntu 16.04 Version of PHP only 7!!! (Версия PHP только 7 !!!) (в процессе тестирования)
CentOS 7 (в зачаточном состоянии)
Поддерживаемые языки:
ru_RU - русский
en (default) - английский (по умолчанию)
el_GR - греческий (в процессе перевода)
Если на сервере нет поддерживаемой локали, все сообщения скрипта будут на английском.
Основные плюшки:
Metronome XMPP Server (optional)
HHVM (HipHop Virtual Machine) optional
Let's Encrypt (optional)
Дополнительная плюшка:
Установка много версий PHP с помощью phpbrew (в зачаточном состоянии)
Будет сделана обёртка в виде знакомых уже диалоговых менюшек для управления phpbrew.

Подробности по плюшкам гуглите :-)
Описывать все изменения, исправления и т.д. пока нет времени...
Надеюсь, что всё получится... :-)

Serg
Serg
Репутация: 1
Лояльность: 1
Сообщения: 5
С нами: 9 месяцев 15 дней

#5 Serg » Ср, 7 декабря 2016, 7:58

Установка много версий PHP с помощью phpbrew

А он умеет php-fpm на разные порты назначать, чтобы php-fpm для каждого PHP работали параллельно?

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#6 SinglWolf » Ср, 7 декабря 2016, 8:14

Serg, насколько я понял из проштудированных манов, автоматом не умеет, ибо для php-fpm нужно писать драйвер для обслуги демона (баш-скрипт в каталоге /etc/init.d/), у каждого дистрибутива своя специфика.
Но... у меня будет автоматом :-[ надеюсь, что будет... :-D

kobzev1711
kobzev1711
Репутация: 0
Лояльность: 0
Сообщения: 1
С нами: 8 месяцев 28 дней

#7 kobzev1711 » Вс, 25 декабря 2016, 17:12

Здравствуйте. Пытаюсь скачать скрипт. Пишет что вы не авторизованы для чтения этого раздела. :'(

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#8 SinglWolf » Вс, 25 декабря 2016, 20:26

kobzev1711, доступ в этот раздел платный (Цена скрипта).

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#9 SinglWolf » Пт, 6 января 2017, 14:31

Небольшой анонс.
Версия 4.1Beta6
Ubuntu 16.04 - пока только Apache и Nginx
Debian 8 - комплект
Подробности в теме.

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#10 SinglWolf » Вс, 8 января 2017, 20:42

Плохая новость
Спойлер
Шаблоны для виртуальных хостов в ISPConfig 3.1 теперь другие и плагин nginx reverse proxy не работает :(
Автор плагина забил на плагин 2 года назад. Его недавно спросили про ISPConfig 3.1. Вежливо отписался, мол
Thanks for your interest in the plugin. Sadly I cannot answer your question, as I do not have any server running on 3.1 yet. Given 3.1 is quite different in many aspects (at least visual and feature vise) I would guess that the underlaying structure has changed a lot as well and made the plugin incompatible. But one would need to test this...
Так что про Nginx+Apahe в ISPConfig 3.1 придётся забыть :'(

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#11 SinglWolf » Ср, 12 апреля 2017, 5:28

Хорошая новость. Nginx+Apahe в ISPConfig 3.1 работает!

niktel505 M
niktel505 M
Возраст: 50
Репутация: 5
Лояльность: 1
Сообщения: 25
С нами: 5 лет 6 месяцев
ICQ

#12 niktel505 » Пн, 5 июня 2017, 11:39

SinglWolf писал(а):теперь будет создаваться отдельный архив с приставкой -upd.
А для 4 версии скрипта где его искать?

SinglWolf M
Автор темы
Аватара
SinglWolf M
Автор темы
Возраст: 46
Репутация: 197
Лояльность: 71
Сообщения: 1272
С нами: 5 лет 7 месяцев
Откуда: Башкирия
ICQ

#13 SinglWolf » Чт, 8 июня 2017, 22:12

niktel505, отдельный архив с приставкой -upd будет в следующем релизе, ибо все предыдущие версии теперь несовместимы в плане структуры хранения изменяемых данных.


Вернуться в «Проекты»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 2 гостя