Уважаемые гости и пользователи форума!


Тема для обсуждения ISPConfig Installer 5.

Движок phpBBex, вероятно, прекратил своё развитие.
Перевёл форум на phpBB 3.2.1

Перед первым входом на форум желательно Удалить cookies форума и очистить кэш браузера.
Если Вы были зарегистрированы на старом форуме, а здесь не можете зайти под своей учётной записью, пожалуйста, сообщите свой ник мне через контактную форму "Связаться с администрацией"

Скрипт: автоматическая установка ISPConfig 3 [FAQ]

Здесь размещены проекты серверных сборок и панелей управления вебхостингом

Модераторы: rewuxiin, kulia

Правила форума
Условием использования нашего форума, является соблюдение настоящих Правил форума.

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам, а вы рискуете получить предупреждение.
gri
Сообщения: 3
Зарегистрирован: 22 окт 2013, 05:25

Сообщение gri » 07 сен 2014, 00:26

Вопрос следующий, при запуске скрипта, выводится ошибка

Код: Выделить всё

eth0: error fetching interface information: Device not found
Интерфейс изначально назван p33p1, ОС ubuntu 12.04/ *HELP*
Аватара пользователя
SinglWolf
Сообщения: 1307
Зарегистрирован: 23 янв 2012, 22:11
Откуда: Башкирия
Контактная информация:

Сообщение SinglWolf » 11 сен 2014, 12:03

gri, найдите в файле conf/var.sh строку содержащую

Код: Выделить всё

export IP_HOST=$(ifconfig eth0
eth0 замените на своё значение.
Начиная с версии 3.0.6 эта проблема решена
Аватара пользователя
ujhjl
Сообщения: 54
Зарегистрирован: 27 авг 2013, 18:23

Сообщение ujhjl » 28 фев 2015, 01:41

Добрый день, так все таки что нужно сделать, чтобы отображались картинки, в связке Nginx+Apache, при переходе http://example.com/pma
вроде обещали пофиксить это? или необходимо на другой порт пересадить ни очень понял. :-|
Аватара пользователя
Дмытрык
Сообщения: 111
Зарегистрирован: 05 фев 2014, 19:11

Сообщение Дмытрык » 28 май 2015, 14:58

Та же история! Присоединяюсь к вопросу 3.0.6
все так как описал товарищь
/viewtopic.php?p=6297#p6297
вообщем не работает!

[upd=1432819552][/upd]
И еще такой вопрос, а в связке должно работать CGI или нет чтото не одно приложение не могу запустить Ошибка 500 и все??
Аватара пользователя
ujhjl
Сообщения: 54
Зарегистрирован: 27 авг 2013, 18:23

Сообщение ujhjl » 05 июл 2015, 15:03

Как запустить скрипт на 8.1 debian ? *SCRATCH*
Планируется ли обновление?

Код: Выделить всё

Script started on Вс 05 июл 2015 16:00:28
******************************************* ОШИБКА *******************************************
Поддержка Вашей операционной системы на этом сервере ещё не реализована
AutoInsall-full v.3.0.6. Пожалуйста, перейдите по указанной ниже ссылке, чтобы получить
свежую версию AutoInsall-full и узнать список поддерживаемых Linux/BSD дистрибутивов и версий.
http://forum.mini-server.ru/viewtopic.php?f=33&t=922
******************************************* ОШИБКА *******************************************

Script done on Вс 05 июл 2015 16:00:28

по ссылке указанной нет темы *SCRATCH*

[upd=1436117271][/upd]
Не получилось установить на 8 debian, вернулся на 7 и обнаружил что он стал выкидывать ошибку при попытке установить phpmyadmin, похоже не может его скачать, подскажите что нужно подправить в скрипте? :(

[upd=1436117368][/upd]

Код: Выделить всё

.[42m< ИНФОРМАЦИЯ >.[0m  Установка  ISPConfig 3 завершена
.[H.[2J.[H.[2J.[42m< ИНФОРМАЦИЯ >.[0m  Установка phpMyAdmin версия 4.2.11.

.[42m< ИНФОРМАЦИЯ >.[0m  Скачивание архива с downloads.sourceforge.net/project/phpmyadmin

tar (child): phpMyAdmin-4.2.11-all-languages.tar.bz2: Функция open завершилась с ошибкой: Нет такого файла или каталога
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
.[H.[2J.[41m< ОШИБКА >.[0m Что-то пошло не так...
Аватара пользователя
kulia
Сообщения: 139
Зарегистрирован: 28 май 2014, 14:59
Откуда: Москва

Сообщение kulia » 14 июл 2015, 02:44

В тексте скрипта phpmyadmin.sh выставляем правильную (последнюю) версию и правильную ссылку на ресурс скачивания. Кстати, последний clamav ставится таким же манером, только правим другой скрипт... Удачи!!! *DRINK*
Создал на Линукс-форуме тему "Установка Internet Explorer под Убунту".
Тему удалили через 4 минуты, выдали бан на 10 дней...
Аватара пользователя
kulia
Сообщения: 139
Зарегистрирован: 28 май 2014, 14:59
Откуда: Москва

Сообщение kulia » 15 июл 2015, 01:08

К посту выше.

Измените строки в соответствующих скриптах и будет Вам счастье. *YAHOO*

phpmyadmin.sh

[spoiler]

Код: Выделить всё

###
ver="4.4.11"
###
ECHO_INFO " Скачивание архива с downloads.sourceforge.net/project/phpmyadmin\n"
https://files.phpmyadmin.net/phpMyAdmin/4.4.11/phpMyAdmin-4.4.11-all-languages.tar.bz2
wget -N "https://files.phpmyadmin.net/"${apps}"/"${ver}"/"${rcpacked} >> ${I_Info} 2>> ${I_Err}
###
[/spoiler]

clamav.sh

[spoiler]

Код: Выделить всё

###
ver1="0.98.7"
###
ECHO_INFO " Скачивание архива версия ${ver} с downloads.sourceforge.net/project/clamav\n"
wget -N "http://downloads.sourceforge.net/project/clamav/"${apps}"/"${ver}"/"${packed} > /dev/null 2>> ${ROOTDIR}/install_error.log
###
[/spoiler]
Создал на Линукс-форуме тему "Установка Internet Explorer под Убунту".
Тему удалили через 4 минуты, выдали бан на 10 дней...
Аватара пользователя
SinglWolf
Сообщения: 1307
Зарегистрирован: 23 янв 2012, 22:11
Откуда: Башкирия
Контактная информация:

Сообщение SinglWolf » 15 июл 2015, 06:19

kulia писал(а):Измените строки в соответствующих скриптах и будет Вам счастье.
Спасибо за проделанную работу конечно, но вы забыли про проверку версии ClamAV в файле deb/check_errors.sh (в самом конце)

Код: Выделить всё

if ! echo `clamd -V` | grep '0.98.5'  &>/dev/null; then
надо заменить на текущую версию

Код: Выделить всё

if ! echo `clamd -V` | grep '0.98.7'  &>/dev/null; then
P.S. Всё никак не дойдут руки до обновления скрипта. Увы, свободное время появится только ближе к осени... :(
Аватара пользователя
kulia
Сообщения: 139
Зарегистрирован: 28 май 2014, 14:59
Откуда: Москва

Сообщение kulia » 15 июл 2015, 08:31

SinglWolf писал(а):вы забыли про проверку версии ClamAV в файле deb/check_errors.sh (в самом конце)
Действительно здесь не правил. На будущее теперь буду знать *OK*. На Ubuntu 14.04, clamav 0.98.7 встал нормально, о чем IspConfig3 бодро рапортовал зеленой полосой в мониторе :-)
Создал на Линукс-форуме тему "Установка Internet Explorer под Убунту".
Тему удалили через 4 минуты, выдали бан на 10 дней...
Аватара пользователя
ujhjl
Сообщения: 54
Зарегистрирован: 27 авг 2013, 18:23

Сообщение ujhjl » 16 июл 2015, 22:58

О спасибо парни, пошел тестить. :-)
Аватара пользователя
Xizel
Сообщения: 25
Зарегистрирован: 17 сен 2012, 16:48
Откуда: Брест

Сообщение Xizel » 26 июл 2015, 13:57

Спасибо огромное , а то сидел разбирался! Будем ждать обновления! *PARDON*
Еще Nginx + Apache ssl - не работает. В версии с Apache все отлично.
Аватара пользователя
ujhjl
Сообщения: 54
Зарегистрирован: 27 авг 2013, 18:23

Сообщение ujhjl » 10 сен 2015, 10:01

Добрй день, добрался переставил на debian 7.0.8
Но в phpmyadmin выскакивает предупреждение

Хранилище конфигурации phpMyAdmin не полностью настроено, некоторые расширенные функции были отключены. Для определения причины.
Или перейдите на вкладку 'Операции' любой базы данных, чтобы настроить там.


Конфигурация pmadb… Не готово Документация
Основные возможности связей Недоступно

Что необходимо подправить?
Аватара пользователя
SinglWolf
Сообщения: 1307
Зарегистрирован: 23 янв 2012, 22:11
Откуда: Башкирия
Контактная информация:

Сообщение SinglWolf » 10 сен 2015, 13:16

ujhjl писал(а):Что необходимо подправить?
В принципе, ничего поправлять не нужно, основной функционал работает. Предупреждения выскакивают потому, что не прописана инициализация дополнительных функций, которых не было на момент написания скрипта для установки phpmyadmin. В октябре будет обновление скрипта, там всё будет ОК.
Аватара пользователя
ujhjl
Сообщения: 54
Зарегистрирован: 27 авг 2013, 18:23

Сообщение ujhjl » 10 сен 2015, 13:25

Разобрался, подправил config.inc.php в phpmyadmin, импортировал таблицу :-) Ошибка исчезла.
ZoRG
Сообщения: 75
Зарегистрирован: 11 июн 2011, 20:10

Сообщение ZoRG » 25 сен 2015, 16:04

Добрый день кто подскажет где подправить скрипт чтобы по умолчанию установилась php 5.5 вместо php 5.4 на debian 7
Аватара пользователя
ujhjl
Сообщения: 54
Зарегистрирован: 27 авг 2013, 18:23

Сообщение ujhjl » 19 окт 2015, 14:19

Такая же беда нужен php версии 5.5, обновил руками версию.
Когда уже обновление выйдет скрипта? *SCRATCH*
Аватара пользователя
SinglWolf
Сообщения: 1307
Зарегистрирован: 23 янв 2012, 22:11
Откуда: Башкирия
Контактная информация:

Сообщение SinglWolf » 19 окт 2015, 18:49

ZoRG писал(а):кто подскажет где подправить скрипт
Подправлять скрипт я не буду, проблема решается в другом месте.
ujhjl писал(а):Когда уже обновление выйдет скрипта?
Конец октября-начало ноября. Только-только появилось свободное время.
Аватара пользователя
SinglWolf
Сообщения: 1307
Зарегистрирован: 23 янв 2012, 22:11
Откуда: Башкирия
Контактная информация:

Сообщение SinglWolf » 30 май 2016, 21:59

finger
Сообщения: 1
Зарегистрирован: 08 ноя 2013, 17:35

Сообщение finger » 10 июн 2016, 20:13

В момент установки скрипта версии 3.0.6 по ssh случайно закрыл ssh, сессия оборвалась, при повторном запуске вылетала ошибка.

Код: Выделить всё

 AutoInsall-full:_Простое_Open_Source_Решение_Установки_ISPConfig_3
 ------------------------------------------------------------------------------

              +------------------------------------------------+
              | Установка веб-серверов: Nginx - frontend,      |
              | Apache - backend.                              |
              |                                                |
              |                                                |
              |                                                |
              |  +------------------------------------------+  |
              |  |                    60%                   |  |
              |  +------------------------------------------+  |
              +------------------------------------------------+

 AutoInsall-full:_Простое_Open_Source_Решение_Установки_ISPConfig_3
 ------------------------------------------------------------------------------

              +------------------------------------------------+
              | Установка пакета(ов) не удалась!               |
              | Пожалуйста, проверьте логи установки           |
              | /autoinstall-3.0.6+PHP/info_install.log и      |
              | /autoinstall-3.0.6+PHP/error_install.log       |
              |                                                |
              |  +------------------------------------------+  |
              |  |                    60%                   |  |
              |  +------------------------------------------+  |
              +------------------------------------------------+


< ОШИБКА >  Аварийное завершение работы!
Script done, file is autoinstall.log
updating: autoinstall.log (deflated 90%)
updating: error_install.log (deflated 55%)
updating: info_install.log (deflated 87%)
updating: repo.log (deflated 89%)
В конце error_install.log

Код: Выделить всё

2016-06-09 13:41:27 (45,4 MB/s) - `jcameron-key.asc' saved [1320/1320]

--2016-06-09 13:41:27--  http://nginx.org/keys/nginx_signing.key
Resolving nginx.org (nginx.org)... 206.251.255.63, 95.211.80.227, 2001:1af8:4060
Connecting to nginx.org (nginx.org)|206.251.255.63|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1559 (1,5K) [text/plain]
Saving to: `nginx_signing.key'

     0K .                                                     100% 58,5M=0s

2016-06-09 13:41:28 (58,5 MB/s) - `nginx_signing.key' saved [1559/1559]

E: Существуют проблемы, а параметр -y указан без --force-yes
В логе info_install.log

Код: Выделить всё

Уже установлена самая новая версия ssl-cert.
Уже установлена самая новая версия apache2-suexec.
Уже установлена самая новая версия libapache2-mod-fcgid.
Уже установлена самая новая версия libapache2-mod-rpaf.
НОВЫЕ пакеты, которые будут установлены:
  nginx
Пакеты, которые должны были бы остаться без изменений, но будут заменены:
  libapache2-mod-python
Пакеты, которые будут обновлены:
  libapache2-mod-python
обновлено 1, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 2 п
Необходимо скачать 0 B/1 184 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 2 469
В моем случае проблема решилась следующим способом.

apt-get purge libapache2-mod-python
apt-get purge nginx
apt-get purge apache2

После этого спокойно все установилось.
Аватара пользователя
Xizel
Сообщения: 25
Зарегистрирован: 17 сен 2012, 16:48
Откуда: Брест

Подключение репозиториев EPEL, REMI, RPMforge в Centos 6

Сообщение Xizel » 05 сен 2016, 23:27

В момент установки скрипта 4.0.0 на CentOS , происходит ошибка http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt- 404.
Оно прописано в check_repo.sh
[spoiler]
rpm --import "http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt" >> ${I_Info} 2>> ${I_Err}
[/spoiler]
Может у кого есть решение?
Ответить

Вернуться в «Проекты»